Skip to content

რამოდენიმე საათის წინ გამოვიდა WordPress-ის განახლება, 4.0.1. ყველას გირჩევთ დაუყოვნებლივ დააყენოთ ეს განახლება.

მისი საშუალებით სწორდება 20-ზე მეტი შეცდომა, რომლებიც ეხება არა მარტო 4.0 ვერსიას, არამედ წინამორბედებსაც. ერთ-ერთი გასწორება ეხება XSS-მოწყვლადობას, რომელიც ბოროტმოქმედს საშუალებას აძლევს გუშვას ნებისმიერი JavaScript-კოდი 3.9 და უფრო ძველ ვერსიებზე. ეს კიდევ ერთხელ ადასტურებს, რომ WordPress (ისევე როგორც ნებისმიერი სხვა პროგრამული პროდუქტი), ყოველთვის დროულად უნდა განახლდეს.

მიუხედავად იმისა, რომ WordPress-ის დეველოპერების გუნდი მხოლოდ ბოლო ორი ვერსიის მხარდაჭერას ახორციელებს (დღეისათვის 4.0 და 3.9), მიღებული იქნა გადაწყვეტილება უფრო ძველი ვერსიებისათვისაც გამოსულიყო განახლება. შედეგად გამოვიდა 4.0.1, 3.9.3, 3.8.5 и 3.7.5 განახლებები.

სისტემის ფონური განახლებები ხელმისაწვდომია 3.7 ვერსიიდან და ამ დროისათვის ყველა საიტი, რომელიც ამ და ყველა შემდეგომ ვერსიაზე მუშაობს, უკვე განახლებული იქნება. თუ თქვენი საიტი ჯერ კიდევ არ განახლებულა, გირჩევთ ეს ხელით გააკეთოთ. ამისათვის შედით: Dashboard —> Updates სექციაში და დააჭირეთ განახლების ღილაკზე.